Message Boards » Technical Support/Need Help

TOPIC: iphone app not working

 
Ic_disabled_photos
Topic has been inactive for 30 days or more and images have been disabled.
Display All Images
September 23, 2010 11:38 AM
My iPhone myfitnesspal app has been frozen on "loading" for the past 4 to 5 hours. What can I do to get myfitness pal to work again?
September 23, 2010 11:42 AM
did you try restarting your phone?
September 23, 2010 11:51 AM
I have tried turning off the iphone several times with no result
September 23, 2010 3:35 PM
I've had the same problem for 3 days! Cant find a solution and unfortunately no information from the developers support system. Can I reload my data from the website if I delete and reinstall the app?
September 24, 2010 2:16 AM
We've had a few reports of this and are still trying to find a solution. Is there any chance you've run out of space on your iPod/iPhone? Can you check and let us know if your device is completely full?

If that is not the issue, you can try deleting and reinstalling the app. If you have been syncing with the website, then when you reinstall, your data will be reloaded from the website. Delete the app from your device by holding your finger down on the icon until it jiggles, then tap the X that appears. Then go to the App store ON YOUR DEVICE, search for "MyFitnessPal", and install it.

If you have not been syncing, then you may lose your data when reinstalling. One thing you can try is deleting the app from your phone by holding down your finger on your icon until it starts to jiggle, then tap the X that appears. Then reinstall the app by syncing it with your computer. If you are lucky, a backup of your data may be on your computer that will be restored when you sync.

Let us know if reinstalling helps to fix the problem.
September 24, 2010 1:49 PM
Thank you for your suggestions. My iphone is new and I have only 2 apps in addition to the ones that came with the phone, so I am sure that I have plenty of space. I deleted the app and reinstalled it but there was no change, even after deleted and reinstalled it a second time. Fortunately my computer entries were not affected, but I miss the convenience of being able to enter food and exercise on my phone.

I love your site. I has been a terrific help to me. Please continue to research solutions to the iPhone problem.
September 24, 2010 2:14 PM
OK - can you answer the following for me?

- you have the new iPhone 4, correct?
- How are you deleting the app and reinstalling it? Please make sure you are doing the following:

1. Hold your finger down on the MyFitnessPal icon until it jiggles, then hit the "X" that appears to delete the app
2. Open the App Store ON YOUR PHONE, search for "MyFitnessPal", and tap on our app. Install it by hitting the "Free" button on our app page.

You need to make sure you are doing all of the deletion/installation on the phone itself. Some people are deleting it and reinstalling it by syncing with their computer, and that can end up just putting the bad copy right back on your phone.

Let us know if that helps.
September 24, 2010 2:15 PM
Also, did the app EVER work for you (on this new phone), or did it get stuck on "Loading..." the first time you used the app?
September 24, 2010 7:14 PM
The app worked wonderfully on my phone for a least a week. Just long enough to get me hooked on it!
September 24, 2010 7:20 PM
I am having the same problem, the 'loading' screen has been stuck for 5 hours now. I have followed your instructions. This is a new iphone 4. The app was working fine for 5 days. I tried to sync the first time. That didn't work. Then I deleted the app from the itunes app store, then reinstalled it on my computer, still the same loading message, after I did a sync to put it back on the phone. I did that twice. Then the last time I followed your instructions to remove it from my phone, and I reinstalled it all from the phone, not connected to the computer. Still the same loading message...........HELP!!! I love the program. Mary
September 26, 2010 8:33 AM
I finally turned the device off, not just the phone, by holding the top button down, the sliding the red off bar, then a few minutes later tunred it all back on, and the same screeen showed up, but then it did allow me to log in.
September 30, 2010 6:40 AM
Mary - I tried you method of turning everything off and it worked!! Many thanks!
Ann
October 1, 2010 4:20 AM
Mike
I was having an issue where all of the data on my iphone was lost. Everything had managed to sync to the website except for anything I entered on Wednesday and Thursday of this week. No clue how or why it happened as it has been seeming to work fine with exception to it saying that it is syncing when it is not.
I couldn't get it to pull the information from the website at all.
I tried your uninstall\reinstall method and it worked. Wednesday and Thursday are still lost but that is way better than nothing being there.

PS...I do have an iPhone4 and I am definitely not even close to capacity.
Thanks.
  2008129

Message Boards » Technical Support/Need Help

Posts by members, moderators and admins should not be considered medical advice and no guarantee is made against accuracy.